DBM issue - auto-disable by force (after numberous outdated warnings)

Post new topic   Reply to topic    Freakz Forum Index -> WoW Freakz - Legion -> General Discussion
Show all posts
Author Message297

[Mentally Stable]

Status: Offline
(online 1 day ago)
Joined: 11 Jan 2019
Posts: 32, Topics: 10
Location: Croatia

Reputation: 5.1

Post Posted: 09-08-2019, 22:14:42 | Translate post to: ... (Click for more languages)


I realize this is probably not the place to post this issue, but I'll do it nevertheless as really I'm running out of options.

What happens is that, after a while (a few weeks usually), and after many repeated warnings about how my Deadly Boss Mods addon is outdated and needs to be updated to a newer version (which far surpasses the current server patch) over those few weeks, the addon suddenly disabled itself by force (so far it's always happened while inside a raid) to "prevent causing issues to other players" and I can no longer turn it back on. It stops working altogether.

Now, I'm given to understand that the commands that operate the described addon version check and the subsequent force disable are located in the DBM-core.lua file.
However, since I'm not a programmer, I'm hesitant to fiddle around all those commands, especially since I'm not even sure where exactly those particular commands are located (I tried searching commands using keywords "version", "check", "disable", "outdated", and I got quite a number of results for each search).

I'd appreciate any help on this issue. If you need additional information, I'll be happy to provide them here or via private messages.

The issue has occured with a couple of different versions of the addon - I tried versions for 7.2.5, 7.3.0, 7.3.5, even one or two BfA versions - always the same issue.


0 0
Back to top
View user's profile Send private message

[WoW GameMaster]

Status: Offline
(online 9 hours ago)
Joined: 30 Jun 2017
Posts: 1422, Topics: 43
Location: Germany

Reputation: 1249.7
Votes: 15

    Battletag: postrow.ID_BATTLE_NET} 
Post Posted: 09-08-2019, 23:13:13 | Translate post to: ... (Click for more languages)

Hello Gadoschi,

The problem happens if someone in a group with you uses a different version of the AddOn than you do. The AddOn detects this, then does a version check, and discovers that there's a more up to date version available (which of course is not meant to be used on a 7.2.5 server though)

Only way around is by having everyone in the group use the same version.

Or, alternatively, use BigWigs, as it doesn't have such features.

If you figure out a way to edit the version scan out of the AddOn, that'd be great, however, I'm afraid I'm unable to assist with that, not familiar with lua programming.

Best regards

0 0
Back to top
View user's profile Send private message
Post new topic   Reply to topic    Freakz Forum Index -> WoW Freakz - Legion -> General Discussion  

The time now is 02-04-2020, 08:27:12
Copyright info

Based on phpBB ro/com


I forgot my password

This message appears only once, so
like us now until it's too late ! :D