User
Pass
2FA
 
 

Double exp no longer work after MOP ?

 
Post new topic   This topic is locked: you cannot edit posts or make replies.    Freakz Forum Index -> WoW Freakz - Legion -> General Discussion -> Q & A
Show only staff posts
Author Message101
Peyote

[Mentally Stable]



Status: Offline
(since 08-06-2019 14:35)
Joined: 23 Mar 2019
Posts: 7, Topics: 4
Location: Indonesia

Reputation: 0.2

Post Posted: 04-06-2019, 15:04:13 | Translate post to: ... (Click for more languages)

I use x10 exp but after i reach WOD content its seems no longer work, i only get normal exp no bonus at all, is it bug or bonus exp not longer work after MOP content ?
0 0
  
Back to top
View user's profile Send private message
LethalFactorLK

[Administrator]



Status: Offline
(online 9 hours ago)
Joined: 24 Jul 2014
Posts: 16364, Topics: 274
Location: The Secret Aerie

Reputation: 8560.7
Votes: 218

Post Posted: 04-06-2019, 15:09:29 | Translate post to: ... (Click for more languages)

Check the xp rates




0 0
  
Back to top
View user's profile Send private message

  Topic locked


Topic is closed, you cannot post any messages in it anymore

Locked by LethalFactorLK, 04 June 2019 15:09



 
Post new topic   This topic is locked: you cannot edit posts or make replies.    Freakz Forum Index -> WoW Freakz - Legion -> General Discussion -> Q & A  


The time now is 15-12-2019, 07:23:18
Copyright info

Based on phpBB ro/com

 
 
 







I forgot my password


This message appears only once, so
like us now until it's too late ! :D
x